1

I have a flow that is setup to be ran through the Field Service Mobile app. Recently I have made some updates to it, specifically having two fields that are set by the flow be set by formulas instead of just values set by the User in the Flow.

When I built it out and ran it through the Flow Debug mode on my desktop there were no errors and everything functioned fine. When I field tested it from within the Field Service Mobile app however, I get an error saying "Hmm, something's wrong with the YourFormular formula. Please contact your admin.".

The formula is syntactically correct and runs fine in other contexts and as I stated above, the entire Flow runs without issue when run via a debug and sets all values and creates all records as expected.

I have checked out the list of Functions that do not work in Flow formulas (https://help.salesforce.com/articleView?id=flow_considerations_design_formulas.htm&type=5) and none of the functions I am using are listed.

The entire formula is also 255 characters and does not hit the limit nor does it reference any other formula fields.

The only functions I am using are: DATETIMEVALUE(), DATEVALUE(), TEXT(), YEAR(), MONTH(), DAY(), VALUE(), MID(). The resources referenced in the formula are all set in a previous step and are both Date/time values.

Thank you in advance and if you need more info let me know.

EDIT: Adding in my formula.

DATETIMEVALUE( TEXT(YEAR(DATEVALUE({!Start_TimeLabor})))+"-"+ TEXT(MONTH(DATEVALUE({!Start_TimeLabor})))+"-"+TEXT(DAY(DATEVALUE({!Start_TimeLabor})))+" "+TEXT(VALUE(MID(TEXT({!Start_TimeLabor}),12,2)))+ MID(TEXT({!Start_TimeLabor}),14,3)+":00")

  • Could you post the formula in its entirety or in some form? The error is about the formula and I don't think anyone would have to much input on what could help without seeing the one piece the error message mentions. – Kris Goncalves Oct 3 '19 at 22:48
  • DATETIMEVALUE( TEXT(YEAR(DATEVALUE({!Start_TimeLabor})))+"-"+ TEXT(MONTH(DATEVALUE({!Start_TimeLabor})))+"-"+TEXT(DAY(DATEVALUE({!Start_TimeLabor})))+" "+TEXT(VALUE(MID(TEXT({!Start_TimeLabor}),12,2)))+ MID(TEXT({!Start_TimeLabor}),14,3)+":00") – DC-Fencer Oct 4 '19 at 15:45
  • Can you check whether your user record has "Run Flows" permission? This permission is available under Profile --> System Permissions – Devendra Oct 8 '19 at 7:24
  • Hi Devendra, yes I have confirmed that all relevant Flow permissions are turned on for the User I am testing this on, but the error still occurs. Thank you. – DC-Fencer Oct 8 '19 at 14:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.