3

I'm desperately trying to configure the creation of scratch org using the scratch org definition file.

I rely on the following documentation: https://developer.salesforce.com/docs/atlas.en-us.sfdx_dev.meta/sfdx_dev/sfdx_dev_scratch_orgs_def_file_config_values.htm

Unfortunately, it doesn't seem to be up to date.

For example, if I add the ChatterAnswers feature to my configuration file, as below, sfdx launches an error:

ChatterAnswers is not a valid Features value.

{
  "orgName": "Demo Company",
  "edition": "Enterprise",
  "features": [
    "Communities",
    "ServiceCloud",
    "Knowledge",
    "WavePlatform",
    "MultiCurrency",
    "Entitlements",
    "LiveAgent",
    "FieldService",
    "AuthorApex",
    "DebugApex",
    "Sites",
    "MarketingUser",
    "DefaultWorkflowUser",
    "AnalyticsAdminPerms",
    "ChatterAnswers"
  ]

Is it me who doesn't follow the instructions well or is it really the documentation? If so, is there up-to-date documentation somewhere?

  • 2
    Chatter answers are deprecated .Are you running issue with any other feature ? help.salesforce.com/… – Mohith Shrivastava Oct 1 at 14:50
  • Thanks @MohithShrivastava ! Yes actually, I had the same problem with "SocialCustomerService" – Martin Lezer Oct 1 at 15:12
0

SocialCustomerService isn’t available until api v47. You will need to set your scratch org to that as well. It is a preview right now.

{ "orgName": "Dreamhouse", "edition": "Developer", "release": "Preview", "features": [ "Communities", "ServiceCloud", “SocialCustomerService”] }

  • Thanks. That's a great tip. But the question is more about the place where I can find a good documentation. Besides the features themselves. – Martin Lezer Oct 2 at 14:33
  • I tried the solution that JimRae mentioned but I still get "SocialCustomerService is not a valid Features value." It doesn't matter that I put "release": "Preview" in the JSON file or if I create Scratch Org with release=Preview argument. – diff Oct 3 at 13:05
  • @MartinLezer I would recommend the Salesforce DX Developer Guide: developer.salesforce.com/docs/atlas.en-us.sfdx_dev.meta/… Just remember, in the upper left corner is the setting for which API version is being represented. For example, if you switch to v46 (which is the current release) then SocialCustomerService is not listed as a valid feature. – JimRae Oct 3 at 16:09
  • @diff I did not actually try it myself, but you are correct, I still get the error with SocialCustomerService specifically. I can create a preview scratch org, that part works, but if I include SocialCustomerService" then I get the error. My guess is that this is a bug, or is just not fully implemented in the preview. – JimRae Oct 3 at 16:14
  • Thanks. I also found out that some features are not mentioned. Even with the version number selected... For exemple: "CustomerCommunityPlus" is working and is not mentioned anywhere... – Martin Lezer Oct 3 at 16:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.