0

thanks for your new SDK update (v6.3.5)!

Our app is unfortunately not yet supporting Xcode 11. When I attempt building with SFMC 6.3.5, I get this error ":-1: Undefined symbol: ___isPlatformVersionAtLeast".

  • Is it possible to build the latest version of the SDK with Xcode 10.2.1?
  • Could 6.3.4 still support iOS 13 pushes? (Pushes stopped working on iOS 13 w/ SDK v6.2.2)

Thanks

  • 3
    Welcome to SFSE! Just to be clear, most of us here aren't directly employed by Salesforce, but rather work with Salesforce as part of our day-to-day jobs. You might find someone else here that has a workaround, but if you're looking for official support then you should probably go through help.salesforce.com/support – Derek F Sep 25 '19 at 18:49
  • @DerekF is right, but some of us monitor the boards and contribute where we can :) – Bill Mote Sep 26 '19 at 12:13
1

We have discovered a build issue and are correcting the MobilePush SDK iOS version and will be releasing a v6.3.6 as soon as possible.

Please check our main docs page at https://salesforce-marketingcloud.github.io/MarketingCloudSDK-iOS/ for updates.

| improve this answer | |
  • The update was published and pushed yesterday; the SDK will now build correctly. – Brian M. Criscuolo Sep 27 '19 at 18:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.