0

When I create a lightning page with Lightning App Builder, I have 2 design options : one for desktop and one for the phone. I customize both for Account object.

Ligthning app builder in Phone mode

I save the page, activate it as org default for desktop and phones, and as App default for all apps for desktop and phones. I save again and go back to any account page in my browser, my customized page displays. Perfect !

But when I connect to mobile, either in browser or Salesforce 1 app, no matter what I try (check permissions, double check activation settings, dis/reconnect...) I still have the standard page with 3 tabs (Chatter, Details, Related). No way to have my ligthning page.

Standard record page on phone

I read here https://developer.salesforce.com/forums/?id=9060G000000UV5SQAW that Salesforce 1 won't use a Ligthning page. If it's true, what is the point of activing pages as default record pages for mobile ? It makes no sense...

What am I missing ? Please help, it's driving me nuts !

  • 1
    I can't seem to immediately find the documentation on this... but you may need to enable the Mobile on Lightning permission... – Chris Johnson Sep 25 '19 at 20:39
  • It does work, thank you so much I'd never have found ! Funny thing my post title was almost the name of the permission I had to turn on :) You should make an answer so I can mark it as best. However is it not insane that there is a complete framework to configure apps for mobile when it's still an experimental feature, without even a notice ? Or did I definitely miss it ? – Emmanuel BRUNO Sep 26 '19 at 11:45
  • Salesforce did seem to put the cart before the horse on this a bit... but I believe the new functionality is slated for GA in the Winter release. – Chris Johnson Sep 26 '19 at 14:07
1

Emmanuel, as you've confirmed... if you want to use the Lightning Page framework for mobile, you must enable the Mobile on Lightning Permission: https://releasenotes.docs.salesforce.com/en-us/summer19/release-notes/rn_general_new_mobile_app_pilot.htm.

In case this link goes away... one ultimately needs to add the "Lightning on Mobile" System Permission to the user... either through a Permission Set or Profile.

  • Unless I'm wrong, it looks like the permission doesn't exist anymore and is not necessary in Winter 20. Didn't find anything in release notes however... – Emmanuel BRUNO Oct 15 '19 at 6:41
  • 1
    The permission has been renamed. It's now "New Salesforce Mobile App." Salesforce has added a "New Salesforce Mobile App QuickStart" option in Setup. You can find it near the top of the Setup menu. The release notes have a section entitled "Salesforce App: Welcome to the New Salesforce Mobile App" that provides some additional information. – Chris Johnson Oct 16 '19 at 14:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.