2

I couldn't get this to work for the current '19 org either, fwiw

According to the Metadata coverage report, I'm supposed to be able to use territory 2 features with this bit of sample scratch definition:

{
  "orgName": "Sample Org",
  "edition": "enterprise",
  "settings": {
    "territory2Settings": {
      "enableTerritoryManagement2": true
    }
  }
}

But, that doesn't seem to work for me.

Full disclosure, here's my full project-scratch-def.json which also features a "release": "Preview" bit so that my scratch org will be Winter 20 (to match our sandbox that got spun up on Winter 20 outside of our control)

{
  "orgName": "Quick Test",
  "edition": "Enterprise",
  "features": ["AnalyticsAdminPerms","Communities","FieldService","Knowledge","MarketingUser","OfflineUser","ServiceCloud","SalesUser","ServiceUser","ChatterAnswersUser"],
  "description":"Initial scratch org for playing around further with CRM model",
  "adminEmail": "[email protected]",
  "hasSampleData": true,
  "release": "Preview",
  "settings": {
    "territory2Settings": {
      "enableTerritoryManagement2": true
    },
    "orgPreferenceSettings": {
      "s1DesktopEnabled": true, 
      "s1EncryptedStoragePref2":false,
      "pathAssistantsEnabled":true,
      "voiceEnabled": true
    }
  }
}

Weirdly, I can go in manually to my Winter '20 scratch org and manually turn on territory mgt (I see the Territory Models, etc)

0

You must log in to answer this question.