1

I am using an OpenCTI Softphone Adapter, and I have recreated a call-center with a test method that explicitly calls searchAndScreenPop method.

I have saved a Person Account record with the phone number and checked the database to ensure that it is formatted correctly, simply 10-digits (no punctuation, no country prefix) just 5661223456.

function searchAndScreenPop() {
   sforce.opencti.searchAndScreenPop({ searchParams : '5661223456',queryParams : '', callType : sforce.opencti.CALL_TYPE.INBOUND,  deferred: false, callback : callback });
}

Yields Response:

"{"success":true,"returnValue":{"SCREEN_POP_DATA":null},"errors":null}"

I am running as a System Administrator, the record should be visible and searchable regardless of sharing settings as SA, and it is in the UI.

Searching for the phone number in the regular global search returns it as the only result?

When I perform the exact same method call in another sandbox I get the search result?!

Record: Record in DB

Softphone Layout Softphone Layout (Searching Person Account)

Call Center Assignment Call Center Assignment

  • Being that you're calling JS, I'd being looking at the Browser's JS debugging Console tools to see what's happening when the method is called. I'd be checking to make certain you're a member of the call center and othing things along those lines to solve this rather than the phone settings unless it hasn't been properly declared as the default. – crmprogdev Sep 15 '19 at 15:13
  • @crrmprogdev I am a member of the call center, I have stepped through each line of the JavaScript, and switched from the minified version of the opencti softphone JS to the full-version. The postMessage from the iframe fires as expected, and returns no results. This is also the only Call Center I have using this adapter layout, thus I can confirm I am a member if I am seeing it. – jordan.baucke Sep 15 '19 at 16:18
  • If I'm not mistaken, an admin can see a call center without being a member of it. I recommend you explicitly check the call center and/or the user profile to see if they have been added to the call center. – crmprogdev Sep 15 '19 at 20:21
  • @crmprogdev adding screenshots demonstrating my user is added to the call-center and the default softphone layout. – jordan.baucke Sep 16 '19 at 15:06
0

Salesforce Tier 3 Support/R&D CTI Team has confirmed the issue we encountered is due to a conflicting naming convention in Softphone Layouts.

Apparently, there is a subtype of Account known as Business Account (Which is not a Person Account?) Also Business Account does not appear in the Object Manager... 🙄

Anyways, both objects appear as "Account" in the Softphone search object selector:

Business Account vs. Account in Softphone Layout

As we had selected the wrong "Account" the query was being built incorrectly on the backend. Salesforce reports they are "Researching if it's possible to differentiate between the two in the selector" (I am not holding my breath).

Support also pointed to a known issue related to Person Account in the Softphone Layout search. Though this is not directly related to resolving this issue, they felt it was relevant to talk to me about it. 🤷‍♂️

Now to go try to find an explanation of Business Account since documentation is sparse.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.