0

In one of our sandbox, we are testing some funcationality which sends the email from workflow when ever a case with specific subject is created. But the problem is email sending is very inconsistent i.e. if I create 4 cases with the desired subject i get only 1 or 2 email.

Also I tested by adding my other teammates to the recipients, and strangely for not all of them are getting email but for every case only 1 or 2 is getting. If I get an email for case my teammate wouldnt get and viceversa.

I checked my junk email too but its not coming there either, and when it comes it comes only to inbox. I checked workflow rules are being trigger as there is another action of updating owner which is working fine, only email is inconsistent.

Any idea or thoughts on this please..

  • have you checked your junk/spam folder? Have you confirmed whether the emails were sent, or whether the workflow ran? – Nick Cook Sep 12 at 5:37
  • @Nick, updated question. emails not coming in Junk/spam and workflow is running – SFKumar Sep 12 at 5:46
  • 2
    Have you checked the email logs to see whether the emails are being sent? – Nick Cook Sep 12 at 6:01
  • I checked the email logs and see all recipients are listed in logs and getting emails. Also when one of us receive email, I can see all in the recipients list, but not all of them received. – SFKumar Sep 12 at 6:11
  • Doesn't that tell you that salesforce is sending the emails, but you're not receiving them? e.g. you should look into your IT's email infrastructure – Nick Cook Sep 12 at 6:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.