I have got 4 custom objects in my Org. and when I view it in Salesforce1, I only want to display 2 of them in the menu. Could anyone suggest me on how to customize the menu in Salesforce1 by allowing to display only those objects that we want.

2 Answers 2


The Smart Search/Recent menu group in Salesforce1 initially shows objects for which the user has recently searched, and when expanded, shows all tabs in Apps to which the user has access. If the user has customized her tabs to add or remove tabs to which they have access from All Tabs but not in an App, then those are the object tabs that are available.

It is not possible to offer a user different tabs in Salesforce1 than they have in the full UI. If you want to limit Salesforce1 access to only two custom objects, the two permitted object tabs should be in an App that the user has access to, and the other two objects' tabs should be Hidden.


The items in the Salesforce1 menu are tied to the available tabs in the full web UI. IF you don't want objects to show up in Salesforce1 then their corresponding tabs need to be Hidden in the web UI.

The behaviour of the menu is covered in this Knowledge Article (000188058).

When a customer has access to a standard or custom object via the + (tabs listing) ONLY but cannot access that object via an application, they will notice that these objects are not available in the Salesforce1 left menu.

Many users associate the tabs (objects) in Aloha with the objects available in Stage Left in S1. When a tab is not available in the Aloha UI via one of the available applications, that object will not be shown within the Salesforce1 Stage Left.

Users experiencing this issue should:

1) Click on the + to the right of the visible tabs within any application
2) Choose 'Customize my tabs'
3) Select any appropriate application and ADD the Standard or Custom object to the 'Available' column
4) Save

Now, the added objects should appear under the Salesforce1 Recent Items section.

This Knowledge Article (000188341) may also be useful:

Salesforce1 app menu does not display the Standard / Custom objects like:



To resolve this issue, follow the below steps:

  • Login to salesforce through the browser.
  • Click on 'Setup'
  • Under Administer

Mobile Administration | Mobile Navigation | Navigation Menu Items

Make sure 'Smart Search Items' appears under the 'Selected' items. If not move 'Smart Search Items' from Available to Selected.

Save the settings.

Login to the Salesforce1 app through a mobile device and you will find all the objects appearing in menu items


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .