6

I keep seeing "Indexing Lightning Components" in Visual Studio Code, which is a CPU and Memory hogging activity, slowing my PC. Is there a way to make it less CPU intensive?

#VisualStudioCode #IndexingLightningComponent #CPUHog

  • Try to close and reopen Visual Studio a few times. I have similar issues on IntellJ IDEA sometimes... – Carlos Naranjo Nov 1 '19 at 0:46
  • Same issue, any solution ? I also tried reopening... – Srujan Dec 7 '19 at 13:02
  • Something is wrong - I'm getting too... I guess I should file a bug with the vscode team – Caspar Harmer Dec 10 '19 at 18:30
3

I added the same comment to Saleforce github issues for VS Code Salesforce dx plugin, and it was marked as a bug by SF team. Seems the issue is with Aura Component extension for VS Code by Salesforce. It can be checked at below link https://github.com/forcedotcom/salesforcedx-vscode/issues/1592

| improve this answer | |
  • Disabling aura component extension removed errors and CPU drain, thank you – Zoran Basic Dec 11 '19 at 15:19
  • Disable aura component extension would be useful is one is not developing in lightning. – aditya Jan 27 at 21:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.