On two of my sandboxes I am getting an error every time I open a class or try to open the schema (the classes load but the schema does not). Other org's are working fine but these two, which are from the same org (one is dev and the other is staging) seem to not like me at the moment.

Error from IDE

I have tried deleting the project completely (off the computer as well) and re-adding it, but still the error persists. I looked for an update via the IDE but it says there is no update. I am on version:

Force.com IDE (OSX)

I am hoping it is an easy fix, but google isn't providing many answers (or I am searching incorrectly lol)

UPDATE Looks like this a bug with Spring 14 only

When I try to open the schema browser, directly after double clicking the salesforce.shema in the package explore I get the error as shown above. Then once I hit 'OK' none of the objects in the browser load:

empty schema browser

however it seems that queries still work.

When I click on any of the classes to open them (pages and others seem to work fine) I get the following error message:

class load error

however the class still loads after the error.

  • Can you confirm if your two affected sandboxes are running Spring '14 or still on Winter '14. My sandbox is on CS3 which has already been upgraded to Spring '14 which I believe occurred this past week or so. Thanks Commented Feb 11, 2014 at 18:23
  • I am looking.. is there a spot i go in the org to check? they switched the setup around and i can find anything anymore :-P Commented Feb 11, 2014 at 18:35
  • it is on spring 14 for sure Commented Feb 11, 2014 at 18:38
  • 4
    Seems like a bug, new features shouldn't break old APIs. I've passed this onto the relevant team, I'll post a bug # when i have one.
    – superfell
    Commented Feb 11, 2014 at 21:03
  • 5
    This is a server bug in the spring release, its being tracked as W-2036818
    – superfell
    Commented Feb 12, 2014 at 3:26

6 Answers 6


I also have the same problem. Unfortunately, per Mark's suggesting, creating a new project does not resolve the issue. I've been getting this issue ever since the release of the new Spring '14 in our sandboxes. Coincidence?

More info...

  • Running Win7 Ultimate, Eclipse Kepler Service Release 1 Build ID: 20130919-0819
  • Salesforce.com API version
  • This appears to ONLY occur on projects against Spring '14 Release sandboxes.
  • No error occurs when connecting to projects still on Winter '14 release.
  • Also tried, reinstalled Eclipse Kepler and installed the Force.com IDE per exact instructions from the developer.force.com site. Same results.

Any other thoughts would be greatly appreciated.

  • thats what I am noticing.. :-( there is a chance that the full version of eclipse (using the plugin) might work, but the plugin only works with older versions of eclipse :-( I was hoping the IDE would be better since its been out of a few years and they fixed most of the issues that came up initially. I think we need to wait for a patch :-( Commented Feb 11, 2014 at 18:24
  • I'm running the full version of Eclipse with the Force.com IDE plugin. So its not that. :( Commented Feb 11, 2014 at 18:25
  • darn! well thanks for saving me the trouble of the install lol Commented Feb 11, 2014 at 18:36
  • No problem. I'll keep looking and keep you updated. I'll also submit a Case to Tech Support and suggest you do the same. Please keep me posted should you find anything more out from your side. Thanks again! Commented Feb 11, 2014 at 18:45
  • O yea, and the plugin now works with newer version of Eclipse. I'm running it with Kepler atm.
    – dphil
    Commented Feb 11, 2014 at 19:26

Are you using the new Geolocation feature in Spring '14? See the "Address and Geolocation Compound Fields in the SOAP and REST APIs—Beta" section in the release notes PDF.

If so, then that new type (or, SoapType to follow the terminology in the error) is not supported in older versions of the Force.com IDE. The location type was newly introduced (and in beta) for Spring '14. The new version of the IDE will support that. It usually comes out a week or two after Spring '14 is released to everyone.

Depending on what you are trying to do, you might be able to use Workbench

On the other hand, if you are not using the new Geolocation feature but are still running into this issue, then could you provide more details?

  • It looks like we are NOT using that feature (although we plan to in the future) What other details would be needed? Let me know, happy to help in any way! Commented Feb 11, 2014 at 20:31
  • Here's how I got the error to show up. I added a new CustomObject with a CustomField of Location. Then I opened the "Schema Browser" in Eclipse. Without clicking on any particular SObject, I got the error dialog in your screenshot. Did you have to select any particular SObject to get the window to show up?
    – vazexqi
    Commented Feb 11, 2014 at 21:25
  • just clicking to open the browser gives the error, and i dont see any objects once i hit ok.. so nothing loads in the schema at all Commented Feb 11, 2014 at 22:22
  • added more info in main question with screen shots... Commented Feb 11, 2014 at 22:30

it looks like this is fixed, thanks @superfell!


Have you tried running as an Admin? It's a long shot but sometimes that helps. (Looks like you're on a Mac, I'm not familiar if they have similar such commands)

  • interesting thing to try.. I remember that when I used to use windows.. however why would all of my other Eclipse projects/orgs work but one? I'll see if I can try it though.. Commented Feb 11, 2014 at 18:11
  • When it comes to SFDCs environments/tools... hardly anything seems consistent. Things are getting slightly better but far from consistent. I noticed when using Windows, I have to run as Admin often when I use the standalone Force.com IDE fairly often but when I use the Eclipse plugin I never have the issue.
    – dphil
    Commented Feb 11, 2014 at 18:17
  • I normally use sublime text but it has issues with the mavens mate plugin rendering it useless, otherwise in the past i have used eclipse with the force.com plugin, but opted to use the force.com ide this time around.. guess i'll have to install eclipse the real version.. it just stinks that the force.com plugin for it only works with older versions.. Commented Feb 11, 2014 at 18:21

I've been seeing this in full Eclipse as well. I think it's related to the changes in Location fields (Release notes, page 236) that are happening in Spring 14. I just set up Eclipse Kepler with the latest force.com plugin to see if it would resolve the issue and no dice.


This is rather strange but I was able to resolve Spring 14 issue by:

Deleting the old project and creating new project.

When creating new developer sandbox. This sandbox wasn't a Full Sandbox but a developer/configuration sandbox. Normally when retrieving a sandbox I would specify the environment as Other and specify target url i.e. cs8.salesforce.com.

To refresh a Spring 14 developer / configuration sandbox had to select Environment: Sandbox

Finally to refresh the project (without the LocationNot error) one cannot right click and refresh.

Instead had to go into the project right click > force.com > Add/Remove metadata components. Try to find a component with very few objects. I used scontrols as this org has no scontrols. Once the project metadata has changed you will then be asked to refresh project components. This will successfully refresh you project.

You can repeat this refresh process by adding/removing metadata components to the project manifest. Then refreshing..

Painful but appears to work until SFDC has fix.. Good Luck!

  • Note: this isn't really a fix but a workaround that allows one to refresh the project and continue to work. Does not fix the issue with the object explorer not showing any objects nor does it fix the issue with the refresh not working correctly.. Commented Feb 11, 2014 at 23:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .