0

Having an odd problem. Has anyone else had unusual behavior with products and process builder?

In this scenario I created a product called Repeat Customer and then added it to a Process Builder. Once I did this, the item was being added twice to quote line items for no apparent reason. So I decided that I would create a new product. All of the values are the same, and the second product is not creating a duplicate line item.

After changing the name of Repeat Customer ==> rpt Customer I realized that the product was being added by default to every quote line item. After deactivating the product, rpt Customer, I was able to get the process builder to behave appropriately.

Anyone else ever had this, and if you did do you know why it did this?

  • 1
    do you have product rules configured? See middha.com/2018/07/salesforce-cpq-automatically-add.html – cropredy Aug 29 '19 at 23:44
  • Thanks for the quick response. Currently, we don't have CPQ enabled. It seems that this is what is required to add items automatically. Not sure what default options would cause the item to be added automatically. – thinker Aug 30 '19 at 12:24
  • You'll need to post your PB. Plus look thru the debug logs to gain insight as to whether some other PB or trigger is executing causing the PB to fire twice for this particular product2 – cropredy Aug 30 '19 at 15:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.