0

First time using Components - putting it in a VisualForce page to leverage on a Force.com Site. The Component works just find on the VF page accessing when logged in (https://mydomain/apex/Testpage). However, when trying to access the page via a Site, it doesn't show up, and shows an error like: An Internal Server Error has occurred (see image) enter image description here

The page permissions themselves appear to be working just fine. I include a paragraph tag on the page and it displays along with the error (indicating to the me VF page permissions are viewable by the External Site Guest User)

Are there special permissions needed for the components in some way to display the component on the VF page via a Force.com Site? What am I missing to have the component show on the VF page via Sites?

Page Code

<apex:page showHeader="false" standardStylesheets="false"><apex:includeLightning/>
<div id="lightning" />

<script>
    $Lightning.use("c:TestApp", function() {
     $Lightning.createComponent("c:ContactExample",{},"lightning", function(cmp) {});

    });
</script>
<p>Test page 1</p></apex:page>

App Code

<aura:application access="GLOBAL" extends="ltng:outApp" implements="ltng:allowGuestAccess" >
<aura:dependency resource="c:ContactExample"/>
</aura:application>

Components Code

<aura:component controller="dataTableController" implements="force:appHostable,flexipage:availableForAllPageTypes,flexipage:availableForRecordHome,force:hasRecordId,forceCommunity:availableForAllPageTypes,force:lightningQuickAction" access="global">
<aura:attribute name="searchTerm" type="Map" default="{'name':''}"/>
<aura:registerEvent name="contactSearchComplete" type="c:contactSearchEvent"/>
<lightning:input type="Text" label="Enter Contact Name" aura:id="searchTerm" value="{!v.searchTerm.name}"/>
<lightning:button label="Search" onclick="{!c.doSearch}" /></aura:component>
1

Appears I didn't have the correct permissions to the child objects that the components shows for the Guest Site User that is used for the force.com site. Change permissions for that user, all is now well.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.