2

We have been using the trigger "Trigger on Email Message " on the link below for more than 2 years without any issues.

http://wiki.developerforce.com/page/Auto-completion_of_Case_Milestones_with_Triggers

Yesterday, I noticed that our sandboxes (even those not in the Spring 14) are returning a query exception.

List<Case> caseList = [Select c.Id, c.ContactId, c.Contact.Email,
                              c.OwnerId, c.Status,
                              c.EntitlementId,
                              c.SlaStartDate, c.SlaExitDate
                           From Case c where c.Id IN :emCaseIds];

"No such column EntitlementId on entity Case....."

I don't understand why all of the sudden we are seeing this error if it has been working for so long.

If look at the documentation for the case object http://www.salesforce.com/us/developer/docs/api/Content/sforce_api_objects_case.htm#topic-title

There is no such column but it does appear on this diagram as still doesn't explain why it was working before.

http://www.salesforce.com/us/developer/docs/api/Content/sforce_api_erd_support.htm

Any ideas on what might be happening? A salesforce bug?

10
  • did you get this working?. I am also getting the same error. Commented Feb 17, 2014 at 12:19
  • Nope, currently escalated to R&D in salesforce.
    – PepeFloyd
    Commented Feb 17, 2014 at 13:18
  • Even we are facing the same issue. Did you find any solution / work around for this issue. Please share the solution.
    – user6931
    Commented Feb 19, 2014 at 6:26
  • Nope, the issue is still being investigated by Salesforce support.
    – PepeFloyd
    Commented Feb 19, 2014 at 8:34
  • @RoshanSahatiya have you had any luck resolving this issue? Salesforce support doesn't have a clue on what's going on.
    – PepeFloyd
    Commented Feb 25, 2014 at 10:51

3 Answers 3

1

If anyone is still facing the error, please enable the entitlement management in your org to resolve this.

Enable entitlement management. From Setup, enter Entitlement Management in the Quick Find box, then click Entitlement Management > Entitlement Settings. Select Enable Entitlement Management, and save your changes. Also please make sure your field is visible to a given profile. Check Field Accessibility from Setup for that.

For more details, please check Entitlement Management Trailhead

0

If this is occurring in every sandbox, I would suggest checking your profiles, did someone push an update that removed visibility to the field. If it is just the new sandbox, I would check to make sure that Entitlements are enabled. That field is not visible on the case until Entitlement Management is enabled in the org.

0

Long story short, we have a trigger that is fired on a related operation, this trigger is using a global describe on the case object, since the trigger was a on old API version (prior to entitlements) it was not returning this column, the value was cached so it affected the operation on the next trigger. The solution was to change the version to a more recent one.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .