0

I had to create a profile that was significantly more restricted than any of our other profiles. In the process of creating this profile, I have ended up causing an important formula field with an image to only display the alt text. Does anyone know where to change this on the Profile permissions?

Already tried... Enabling Read on Documents and Assets. But still can't determine which profile setting would prevent this from working correctly.

  • Can you share the formula field? Does it definitely point to files that are stored in Documents or Assets? – Thomas Taylor Aug 26 '19 at 19:12
0

You can try to add "Access Libraries" in administrative permissions.

Also, be sure that your asset or your library is shared to this profile. On the App Launcher, navigate to files and then share assets and libraries that contains those images with your new profile.

  • This feature was already there. Shared the file with the user that has the profile, but still no dice. Any other suggestions? – thinker Aug 27 '19 at 18:35
  • Another thought, if you uploaded those images on classic salesforce, at the time, you might need to share the folder containing them. Switch to salesforce classic, navigate to "document" and share folders to your profile. – Romain Corone Aug 28 '19 at 7:34
  • our salesforce instance has never been on classic. Will take a look though, but I'm not sure that it would apply... – thinker Aug 28 '19 at 17:43
0

We figured out. Thanks for your comments about the Libraries. We aren't sure if there was an update to make our logos stop working, because they actually stopped working on our current users suddenly.

Either way, it's not enough to actually have an image file in Salesforce. You have to upload that asset to a library, and during that flow it will allow you to select an option for internal users. Here is the documentation on it:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.