0

I have a custom field as previous owner in account lookup to user object

Whenever I modify an account the previous owner field should get updated as account owner.

I tried it using workflow and process builder...but i cant seem to get it correct

  • In Process Builder, you create a new process when a record is changed, you set the object to Account, insert filter criteria if required, and then you insert 'Update Record' as an action. To set new field values 'Previous Owner' for the records you update, you need to use a Field Reference. – user40501 Aug 23 '19 at 8:08
  • Where exactly do you experience your problems? – user40501 Aug 23 '19 at 8:08
0

A process builder can do the trick.

enter image description here

enter image description here

Here is the Update field Action :

enter image description here

That should work.

| improve this answer | |
  • What is the prior value here? – Soham Chakraborty Aug 23 '19 at 9:06
  • The process builder trigger when the Account Owner "Is Changed". By using the formula "PRIORVALUE" you return the "old" OwnerID and update your lookup field with it. If you have a user A with an id = '123' owner of the account and you change the Account owner to user B with an id = '456', priorvalue of the Owner field will return '123' and update the field you use for previous owner. – Romain Corone Aug 23 '19 at 9:16
  • Thanks @RomainCorone for the answer – Soham Chakraborty Aug 23 '19 at 9:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.