0

In Marketing Cloud's Automation Studio, we created an automated import file activity based on a file drop trigger (i.e. file naming pattern, not the folder-based drop). Even though the automation runs successfully, we're keep getting a validation error "field not found = 1, required fields = 1 " in the import file activity step (the second step is a SQL). We only have test data (i.e. one contact) in the source csv file that we want to test before going into production. General info: the delimiter is "comma", skip bad data and treat "" as text delimiters are turned on. I've checked the source csv file with notepad+++ and, ',' is indeed set as delimiter. We have no date fields in the source file and all data columns in the target DE are set as "Text" to avoid any mismatch on that account. We tried everything, but keep getting the above validation error.

  • Is this being imported to a DE or a list? Does the DE have any non-nullable fields? Are you satisfying all required fields for the list or DE? – Mark_F Aug 20 at 17:50
  • Hi, it's being imported to a DE. The DE has a Primary Key ("ID") and a non-nullable field ("FED-ID"). Both fields are strings, and I've checked, and the data is in the corresponding fields in the csv source file. That's why this is so strange. – nix9247 Aug 20 at 17:56
  • Have you tried this same file into a DE with no P Key and no non-nullable fields to see what it does and does not pick up? – Mark_F Aug 21 at 17:49
  • Hi, we found the mistake. The csv files were being delivered with the wrong file naming pattern (no %%hour%% at the end of a file). Thanks to all of you guys for your effort! – nix9247 Aug 29 at 11:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.