I have a managed package the contains a Lightning component, which has some configuration options that include a pulldown menu with dynamic choices generated by Apex. datasource='apex://MyClassName' This works fine in my packaging org, and in a patch org, but when deployed as a managed package to other orgs, the pulldown menus are blank -- not even the default value.

This function worked in the previous version I made 2 days ago, but I've made no changes to the component or the Apex class in the interim.

I've checked to assure that the values that the Class needs to access and return are present, valid and accessible.

Here's the code from the meta file for the LWC:

<property name="protonTextAccount" label="Proton Text Account" type="String" datasource="apex://ProtonTextAccountList" />

And the class that returns the values:

 global class ProtonTextAccountList extends VisualEditor.DynamicPickList{

    global override VisualEditor.DataRow getDefaultValue(){
        VisualEditor.DataRow defaultvalue = new VisualEditor.DataRow('Select Proton Text Account', '');
        return defaultvalue;

    global override VisualEditor.DynamicPickListRows getValues(){
        List<Proton_Text_Account__c> ptaList = [
            SELECT PtaId__c, Name
            FROM Proton_Text_Account__c
        System.debug('ptaList: ' + ptaList);
        VisualEditor.DynamicPickListRows  myValues = new VisualEditor.DynamicPickListRows();
        myValues.addRow(new VisualEditor.DataRow('Select Proton Text Account', ''));
        for(Proton_Text_Account__c pta : ptaList){
            myValues.addRow(new VisualEditor.DataRow(pta.Name, String.valueOf(pta.PtaId__c)));
        System.debug('myValues: ' + myValues);
        return myValues;

I don't think there's anything wrong with the code because it works perfectly in the packaging org.


In this same managed package, I have a different component (written in aura) that also has a dynamic picklist to a different class. That one works as expected.

Any ideas?

1 Answer 1


sorry that this is not an accurate response to your question but just a suggestion and a path if somebody looks at this.

Open a case with Salesforce Support.

Some months ago we had a similar issue on one of our managed packages, I can't recall the exact solution but we just needed some changes at the component level (something pretty strange and non expected as it had nothing too do with the code), we debugged it to death and it turned out to be a platform issue solved by support.

  • Thanks Nico, I filed a support ticket yesterday. If they solve it, I'll post back here. Aug 21, 2019 at 13:29
  • The issue is resolved. I filed the support ticket -- it took a day to get it escalated. They called this morning and said the issue is resolved, but he doesn't know exactly what caused it. Nothing wrong with the code, nothing wrong with the package, nothing wrong with the org. He said he was trying to reproduce the issue and just noticed that it was resolved. It just started working. Now I understand why "civilians" thing devs are magic! Aug 22, 2019 at 15:54
  • @PatMcClellan__c hahaha, yeah, those kinds of things happen a lot :D
    – Nico W
    Aug 23, 2019 at 14:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.