-1

I have installed Salesforce CLI and Visual Studio code but when i tried to create a Salesforce project with Manifest I get this error:

(17:02:00.225 sfdx force:project:create --projectname DevSandbox --outputdir c:\Users\prabhat.jha\Documents\C3SDevMetadata\DevOrg --template standard --manifest ended with error spawn sfdx ENOENT Salesforce CLI is not installed. Install it from https://developer.salesforce.com/tools/sfdxcli

enter image description here

1
  • 4
    It seems that your computer isn't convinced that you have installed the CLI though. Have you verified your CLI install?
    – Derek F
    Commented Aug 19, 2019 at 15:19

3 Answers 3

0

Please ensure salesforce CLI environment variable is set. If not go to set an environment variable in your system. Once set the environmental variable restart your device.

3
  • 1
    Please be specific. What environment variable are you telling the poster to set?
    – David Reed
    Commented Aug 22, 2019 at 13:16
  • Hello Everyone,I installed it successfully and it was the Product Issue as explained in this Post github.com/forcedotcom/salesforcedx-vscode/issues/383.Thanks all for your Time for suggestion. Commented Aug 23, 2019 at 9:04
  • Salesforce CLI installed path variable like this "C:\Program Files\Salesforce CLI". Commented Aug 26, 2019 at 7:28
0

It was a Product Issue as explained in Post https://github.com/forcedotcom/salesforcedx-vscode/issues/383 Please check this once before you spent days on fixing this like me. Hope it saves times for other.

0

For me the issue was I had a space in folder path and that is why it was complaining. c:\Users\Salman Zafar\EnvironmentName

Once I removed spaces in the path it worked. c:\EnvironmentName.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .