I am trying to package the Einstein Bot where FAQ__kav is referenced by apex classes. When I try to install the package to other org, it says that there are problems that prevent this package from being installed after doing the following configurations:

  1. Enable Communities in Setup | Communities | Communities Settings
  2. Select a domain name
  3. Create new community in Setup | Communities | All Communities
  4. Create new embedded service deployments in Setup | Feature Settings | Service | Embedded Service
  5. Enable einstein bots in Setup | Feature Settings | Service | Service Cloud Einstein | Einstein Bots
  6. Assign a knowledge user license to a user with a profile of System Administrator
  7. Enable salesforce knowledge in Setup | Feature Settings | Service | Knowledge | Knowledge Settings (Error : Missing Organization Feature: KnowledgeValidationStatus)
  8. Activate Validation Status field (Error: Lightning Knowledge is not enabled, or you are in the unsupported Migration Stage)
  9. Enable Lightning Knowledge (Error: When Lightning Knowledge is enabled, you can’t add an article type.)

Lightning Knowledge and Classic Knowledge use different data models. In Classic Knowledge, you have access to Article Types, like FAQ__kav. In Lightning Knowledge, Article Types are not available. Instead, you use Record Types on the standard Knowledge__kav object. See Compare Lightning Knowledge with Knowledge in Salesforce Classic.

With Lightning Knowledge enabled in the target org, you won't be able to migrate metadata that includes (or depends on) Article Types. You'll need to either

  • Alter your package to support Lightning Knowledge instead of Classic Knowledge.
  • Alter your org to enable Lightning Knowledge.
  • Build your package to use dynamic references exclusively, and dynamically determine whether it's operating in Lightning or Classic Knowledge.
  • Build two versions of your package, one for Lightning and one for Classic Knowledge.
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.