0

When I am using my office network I am not able to deploy code to any sandbox using salesforce dx it shows the timed out error and when I use sfdx force:org:list in CLI it shows all org's connected status as ETIMEDOUT

I have followed all the steps mentioned in the salesforce help from below link but nothing is working still the connected status is timed out, could someone please help me to solve this issue?

https://developer.salesforce.com/docs/atlas.en-us.sfdx_setup.meta/sfdx_setup/sfdx_setup_install_cli_firewall.htm

0

You need to set the environment variable as below:-

Variable    Value
HTTP_PROXY  http://<UserId>:<Password>@proxy.company.com:8080
HTTPS_PROXY http://<UserId>:<Password>@proxy.company.com:8080

If you set the proxy environment variable, and you still see error messages, it’s possible that your proxy requires an extra certificate authority (CA). Ask your IT department where to find or download the certificates.

Set this environment variable to point to the CA file: NODE_EXTRA_CA_CERTS.

Your Corporate Network Is Blocking Salesforce Hosts

It’s possible that your corporate network is blocking the Salesforce hosts for updating or installing Salesforce CLI. Contact your IT department to whitelist these domains:

  • Hi Sanket, thank you for responding after setting the environment variable I am getting a different error Error: tunneling socket could not be established, cause=Client network socket disconnected before secure TLS connection was established – gs650x Aug 13 at 9:51
  • You can post it as separate question as people might not read the comments. – sanket kumar Aug 13 at 9:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.