I am having a problem with my machine when installing Salesforce CLI, I have included the App Path (C:\Program Files\Salesforce CLI\bin), but still, it is not recognized, when I tried doing echo %PATH% in command prompt, it is still not registered in the valid paths, Am I missing a step?

Thanks for the response :)

1 Answer 1


If I understand your issue correctly:

  1. You can execute sfdx command in your command folder: C:\Program Files\Salesforce CLI\bin
  2. That path is not included in your command line path.

If above 2 statements are both correct, you simply need to add that into your path.

For current cmd window:

set PATH=%PATH%;C:\your\path\here\

For permanent setting:

setx /M path "%path%;C:\your\path\here\"
  • Thank you! this was very helpful! turns out, I did not run it as administrator, I was able to set the path now :) Aug 5, 2019 at 2:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .