0

My original objective was to do the prework setting up a CPQ Developer Org for Superbadge Billing Specialist

The first bullet on "Pre-work and Notes" declares:

Default currency is USD and default time zone is PST (necessary for dates and schedulers).

Well, I happen to be living in Berlin and every time I want/need to create a new Developer org, Salesforce gets it into its misguided "head" to help me by setting up the new org in German (couldn't they ask on the signup?)

Okay, fine, well, I know how to fix that -- usually.

So, after first navigating to "Sprache & Zeitzone" in my settings and setting that to "Englisch" so I can see/understand what I am doing, I then go to "Setup" and type Company in the quick find (being very careful not to hit "Enter" because this will break the filter).

Now I click on "Company Information" and get a lovely message which declares:

Insufficient Privileges You do not have the level of access necessary to perform the operation you requested. Please contact the owner of the record or your administrator if access is necessary. For more information, see Insufficient Privileges Errors.

Click here to return to the previous page.

As my user is a System Administrator, this is clearly a bug. Maybe there is some way to hack this problem with Permission Sets, but I don't know it and in addition to completing the superbadge, I want to be a responsible netizen, so I decide to contact Salesforce Support.

I complete the form including the following message:

I'm a Salesforce specialist living in Berlin.

Putting aside the INCREDIBLY ANNOYING assumption that I want my new developer orgs to be created with German as the default language (couldn't you make this part of the setup form?), this TERRIBLE ASSUMPTION, along with a possible defect is making it impossible for me to complete prepare a CPQ Developer Org to complete Billing Specialist superbadge.

Specifically, when I try to view or edit the "Company Information", I get this error:

Insufficient Privileges You do not have the level of access necessary to perform the operation you requested. Please contact the owner of the record or your administrator if access is necessary. For more information, see Insufficient Privileges Errors.

Click here to return to the previous page.

As (username) bmk@XXXXXXX.XXXX is the System Administrator of this new org, this seems to be a defect.

Can you fix this? Or tell me what to do so that I can fix this? Or tell me what to do -- aside from moving or setting up a VPN -- so Salesforce will stop making terrible assumptions about how to set up my developer orgs, playgrounds, etc.?

Thank you!

-Brian Kessler. +49 176 6947 XXXX

and verify my humanity,

However, the "Submit Case" button remains disabled.

Speculating there could be a conflict with a Chrome extension, I turn them all off. No luck. Then I try Firefox, Microsoft Edge Dev, and Brave browser. No, the submit case button still won't enable.

Is there anything I can do to get Salesforce to fix this issue? Is there any way I can complete the superbadge even if Salesforce does nothing to fix this issue?

| improve this question | | | | |
  • 1
    The Trailhead team is quite active on Twitter. That said, the Submit Case function on Trailhead support worked fine for me yesterday, and a quick peek suggests it's operating as expected today. – David Reed Aug 4 '19 at 13:31
  • @DavidReed, I'm not sure what your expectations are but when four browsers refuse to enable the button without indicating any errors or actions i should take to get the button enabled, I'd say that fails to meet my expectations. I don't know if my location being Germany - which apparently screws up creating orgs - can somehow be relevant. – Brian Kessler Aug 4 '19 at 13:56
  • How about manually enabling it via your browser's inspector/debugger? – Phil W Aug 4 '19 at 17:44
  • @PhilW, Good idea but it (the support form) seems to be working now... :-) – Brian Kessler Aug 4 '19 at 21:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.