0

I am trying to configure SMTP Relay with GMail through salesforce. I have white-listed all the email Ips and ranges called out in the salesforce help doc in Gsuite for smtp relay, and it seems to be working for SF email alerts, but not when using APEX outbound emails(Messaging.SingleEmailMessage). When I check the header of the emails sent through APEX, I am finding the SPF IP is not on Salesforce IP Address help article. One example is 13.110.14.189. The emails are still coming through but I am getting SPF SOFTFAIL, and the question mark next on the sender icon from gmail, saying it might be spam. enter image description here enter image description here It seems the IPs also keep changing.

Does anyone know if there are specific IP ranges I need to add to verify my domain? Do I need to set up DKIM?

Thank you for your help!

0

When I check the header of the emails sent through APEX, I am finding the SPF IP is not on Salesforce IP Address help article. One example is 13.110.14.189.

13.110.14.189 is in the first IP address range in the help article, that range being 13.108.0.0 - 13.111.255.255. Please double-check all of the ranges you've entered in to your SPF settings. You need to add the ranges correctly in order for everything to work. You do not need DKIM.

  • Thank you, for replying. I am have added all the IP ranges, but its still failing the SPF test. I cant add the full range 13.108.0.0/14 to the Gsuite settings because it has a limit 65536 per range, so I had to split them up into 4 seperate chunks like this 13.111.0.0/16, 13.110.0.0/16, 13.109.0.0/16, 13.108.0.0/16. Am I doing this wrong? – Thaier Issa Aug 1 '19 at 3:13
  • I solved my issue, my problem was that I had not set up the email domain filter. After I set that up everything worked just fine – Thaier Issa Aug 1 '19 at 13:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.