1

I have a new field on an object that has already been packaged in my package org. This field is referenced in Apex as well.

When I go to my package and look at the components, this field is not pulled in. So when I go to add it, it does not show up in custom fields to add to the package. The field is there!! I have done this before to managed objects (adding an additional field). I don't get what it isn't liking about this one.

I am not getting why the managed package will not recognize it or let me pull it in at all. It is just a simple number field.

0

Because your field is referenced in Apex the managed package is automatically adding it for you to the package, no need to manually add it.

Components Automatically Added

No need to worry, you are good to go!

  • It doesn't show up at all in my items in my package. Before when I've dealt with new stuff it will show up on your package page automatically with no package number associated with it. This time it's not happening – Tyler Dahle Jul 30 '19 at 0:54
  • Nope, just a regular release package. Maybe it just won't show up anymore until you actually package? Maybe they changed how that works? I don't really know – Tyler Dahle Jul 30 '19 at 1:03
  • That is what it sounds like. I had the same issue 2 weeks back and by packaging it it appeared. – Glen De Marcos Jul 30 '19 at 1:03
0

Different package Included By values

Just for reference, the Included By for the custom fields that were automatically added only appeared upon packaging (and if I'm not wrong, during Beta dev it just doesn't appear)

  • Yeah I'm familiar with seeing something like that first field in your image for automatically added stuff on the managed package page you see before you hit 'upload'. But this field is nowhere to be seen – Tyler Dahle Jul 30 '19 at 1:29
  • Let me know how it goes, I just know I saw the same behavior (was looking everywhere for the field to add it but never found it). Good thing is that the field made it in automatically and is now listed. – Glen De Marcos Jul 30 '19 at 1:33
  • 1
    Yay it did just come through when I actually packaged. It had me worried... – Tyler Dahle Jul 30 '19 at 2:18
  • Thanks for confirming! – Glen De Marcos Jul 31 '19 at 0:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.