2

I'm using VSCode for my salesforce development and I installed the Salesforce CLI integration plugin and Salesforce extension pack. Every time I save a source code which gets deployed to Org automatically, (I set that option in the JSON config file), the Salesforce-CLI window on the bottom of VSCode pops up and I have to close it manually. I was wondering if there's a way to turn that off. I can still open the Salesforce-CLI window manually if I need to.

  • VSCode version 1.36.1
  • Extension Pack version 46.7.0

Update on 8/22, this behavior is still the same with the latest versions:

  • VSCode version 1.70.1
  • Extension Pack version 55.8.0

1 Answer 1

1

You can use the "show-cli-success-msg" parameter in your settings.json. According to the plugin:

Salesforcedx-vscode-core: Show-cli-success-msg 
Specifies whether status messages for Salesforce CLI commands run using
the VS Code command palette will appear as pop-up information messages
(true) or as status bar messages (false).

Here my own settings.json:

"salesforcedx-vscode-core.show-cli-success-msg": false
4
  • Thanks for your answer but that setting just changes the pop-up notification behavior. What I'm looking for is the integrated CLI window or section (not sure what it's called but the same one as the integrated terminal with ctr+`). I would like to disable that from popping up on every save or deploy resource to the server.
    – Bahman.A
    Commented Aug 1, 2019 at 17:48
  • 1
    @Bahman.A Same here, did you find any workaround? Commented Jan 9, 2020 at 14:16
  • Hi @Rajendra Singh Nagar no I have not found a workaround yet.
    – Bahman.A
    Commented Jan 9, 2020 at 15:46
  • Also looking for a workaround here Commented Aug 12, 2022 at 16:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .