1

I am currently getting this error code

{ "message": "Internal Server Error", "errorcode": 0, "documentation": "https://developer.salesforce.com/docs/atlas.en-us.mc-apis.meta/mc-apis/error-handling.htm" }

So far these are the steps I have taken:

  1. Set up an installed package (Server-to-server integration) and retrieved an access token
  2. Create a data extension for this API entry event: DE contains fields - subscriberkey (254 text PK), and emailaddress (emailaddress type)
  3. In Journey Builder, I created an API event entry, which generated an Event Definition Key for that event
  4. Tried to fire the event entry, using the event definition key generated:

    {
    "contactKey":"64262",
    "eventDefinitionKey":"APIEvent-238a3ab2-2398-f03e-e6b9-fb2694a3b241",
    "data": {
        "subscriberkey":"64262",
        "emailaddress":"hello@gmail.com"
    }
    

    }

This is where I keep getting this error message, not entirely sure what it means either.

  • payload name should be defined as per the JSON payload defined for the trigger. "contactKey = ContactKey, eventDefinitionKey = EventDefinitionKey and data = Data" – Abhishek Jul 26 '19 at 11:58
  • I changed it to the proper case and it still returns the same error- any idea what caused this? – Julie Nguyen Jul 26 '19 at 14:48
0
  1. The journey that uses your entry event needs to be activated.
  2. It is important that you add all the required fields of your entry event's data extension to the "data"-object of your payload.
  3. Make sure you there is no unique/primary key violation.
  4. If your contact isn't already present in Marketing Cloud, you should add "EstablishContactKey": true to your payload.
  5. Make sure you set the content-type header to application/json
  6. Make sure you provide the accessToken in the authorization header: "Authorization: Bearer [yourtoken]", although this should give a different error message
{
    "ContactKey": "64262",
    "EventDefinitionKey": "APIEvent-238a3ab2-2398-f03e-e6b9-fb2694a3b241",
    "EstablishContactKey": true
    "Data": {
        "subscriberkey": "64262",
        "emailaddress": "hello@gmail.com",
        "requiredDEfield": "something"
    }
}
  • 1
    Hey Markus! Thanks for the response, I've ensured all of the above was complete, still getting the same error message. – Julie Nguyen Jul 26 '19 at 20:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.