1

i have a process builder which change owner of case record when i change status.and i have another process builder whose entry criteria is whenever owner is changed send chatter notification so this PB Never get fired whenever i change status. but it fire when i change owner manually. Any Idea Why would This be Happening I have Tried Everything I know?

0

Instead of calling another process builder on "Record Change" have you tried by invoking another process builder?

1
  • yeah i just tried that but no luck
    – User6670
    Jul 23 '19 at 19:24
0

While Manjunadh's suggestion is also useful, to specifically answer your question, in your second process, have you enabled recursion?


enter image description here

1
  • No i haven't but if i did then chatter notification is sent multiple times
    – User6670
    Jul 23 '19 at 19:23
0

Are you sure, the second PB is invoked whenever record is created/edited or are you invoking the second PB only when record is getting created. Because I don't see any issue why the other PB shouldn't run. Check the invoking criteria of the other PB.

2
  • Both Process builders invoked criteria is record created or edited
    – User6670
    Jul 26 '19 at 14:20
  • May I have the screenshots of both the process builders. Because when you change the case owner in the 1st PB, second PB might be invoked, and it might satisfy any of the nodes before that particular node which checks for change of owner, and you might have not given evaluate next criteria in the previous nodes. These are just my speculations. Make sure to give evaluate next criteria in the previous nodes of 2nd PB Jul 29 '19 at 8:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.