0

After struggling for a week with a CloudPage that wasn't working as expected, I finally noticed that the editor somehow adds an old version of jQuery to every CloudPage after publishing it. Unfortunately, I don't know how to prevent it from doing that - any tips?

This is what I found in all my CloudPages after publishing them and checking the Console, and it's not visible in the editor in CloudPages:

<script type="text/javascript" src="//ajax.googleapis.com/ajax/libs/jquery/1.8.3/jquery.min.js"></script>

I will appreciate any workaround on either preventing this or overwriting this with a higher version of jQuery.

  • what worked, but doesn't seem like the best workaround: inserting the higher version of jQuery at the bottom of the email instead of the <head> – CodeRage Jul 16 at 14:32
3

This is added to make some of the WYSIWYG added components work. If you are not using smart capture or any of the other 'gears', I would suggest creating the cloud page in 'Code View' or creating a code resource instead. Both of these options will prevent jQuery from being added.

  • Hi @Tyler, creating the page in Code View didn’t help - it still added jQuery, but I will check whether creating it in the Classic editor will be any better - thanks! – CodeRage Jul 29 at 17:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.