4

I have an application that is making calls against the REST /services/data/<api version>/query/ endpoint. My Salesforce org has two users: Alice has the "System Administrator" profile, and Bob is a "Partner App Subscription User". I am making queries of various object types as both Alice and Bob successfully.

The problem is when I query the FeedPollChoice object. My query is:

SELECT Id,ChoiceBody,Position,FeedItemId FROM FeedPollChoice WHERE FeedItemId IN ('<feed_item_id_1>', '<feed_item_id_2>') ORDER BY Position

This query works just fine when I run it as Alice. When I run it as Bob, I get this response:

[{"message":"sObject type 'FeedPollChoice' is not supported.","errorCode":"INVALID_TYPE"}]

Some further info:

  • I first noticed this using API version 36.0 (I'm updating legacy software), but I can reproduce it with API version 46.0 as well.
  • As mentioned, Bob is under the "Partner App Subscription User" profile, but this behavior is the same if I switch him to "Force.com - Free User" or "Work.com Only User".
  • This is the only table I've been unable to query as Bob. I have successfully queried FeedItem, UserFeed, and some others.

My research suggests that Bob may not have a required permission to query this particular object, although I cannot find any settings related to it. Is there a specific permission I need to have to query this table, or is this being caused by something else entirely?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.