1

I am trying to export tracking extracts from SFMC to FTP, and then import these tracking extracts in to data extensions for consolidation and in order to perform queries on this data.

I have created an automation that:

  1. Data Extract for Tracking data - successful
  2. File Transfer for moving the Extract from Safehouse to FTP Export folder - sucessful
  3. File Transfer to move the Extract from FTP Export folder to FTP Import folder (prepare for import to SFMC) - successful
  4. Import File to move Extract from FTP Import folder to data extension in SFMC - failed

When i try to open the Extract file in order to confirm column headings for mapping I am unable to - i have an error message that the file cannot be opened and that it is corrupt.

How do i resolve this for a successful automation for all 4 steps?

1

Note that a tracking extract creates a zip-file containing the individual files (like sents, bounces, opens etc.). So make sure that the .zip file extension is used in the file name, otherwise the wrong application might be used to open the file in which case the data may seem to be corrupt.

0

Step 3 is redundant. Create a File Location for when you transfer from the safehouse to this newly created location (it could be a new folder or the/Import folder. Then run the Import Activity from this same location.

  • Thank you @Jackson Chen. Unfortunately this is still not working. I am still failing on the import and it doesnt look like it has anything to do with the file locations. I am still getting error messages of corrupt data in the data extract file. The only TRUE selections in the configuration of the extract are for Bounces and Quote Text. It is a .csv and comma delimited with UTF-8 character encoding. – Kristin de Clerville Jul 8 at 14:41
  • In the Data Extract, make sure you are checking the checkbox for "Include Header" – Jackson Chen Jul 8 at 16:59
  • Thank you @Jackson Chen. Am i missing something because i do not see that option as a check box on the extract configuration. – Kristin de Clerville Jul 8 at 19:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.