0

I have installed latest Force.com IDE in eclipse in my local system. I am unable to create a new project. I am able to enter username, password under force.com project, then when clicking on NEXT button is doing nothing. No error message, No warning symbols. I tried to uninstall IDE plugin and installing it by following These steps. Can anyone tell me what to do to fix this. I did checked eclipse Community forum and there is This thread where a lot of people complained about same issue but No one shared any solutions. I need to push the code to git once I am able to get this fixed. Please help. Thank you. enter image description here

  • Have you tried resetting your security token and entering that as well? Also, while it should work, the Eclipse plug-in will soon be deprecrated in favor of the sfdx CLI and VS Code extensions . The CLI alone will let you extract metadata, which you could then push to git. – Thomas Taylor Jul 2 at 11:30
  • Yes @ThomasTaylor I tried resetting the security token. Yes, I am well aware that SFDX CLI is going to take over all other tools soon. But, In order to push the current configuration to git, I must use Eclipse. – AshSFcloud Jul 2 at 11:33
  • Eclipse uses the Metadata API. sfdx does as well, and can convert from the sfdx project directory format to the metadata src format, as well as extract a ZIP that's in that format. If what you need is to extract metadata in src/ format to then push to git, you don't need Eclipse. If building the package.xml is the sticking point, try this VS Code extension or Ben Edwards's Package Builder app. – Thomas Taylor Jul 2 at 12:23
  • I understand what you are saying @ThomasTaylor But for this client/production, I can not use Visual Studio Code. If I have to, I need permission which I am going to get a denial. I should use Eclipse which is not working/exporting project. – AshSFcloud Jul 3 at 4:48
  • Alright. I have deleted all eclipse files IDE files and installed Neon.3 Release (4.6.3) Now I am able to pull our prod to local. Thank you very much. – AshSFcloud Jul 8 at 8:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.