0

We have two BUs in our Enterprise 2.0 account. One BU is treated as the Parent and the other is treated as a Child.

We recently connected the Child BU to a Service Cloud Sandbox account. We have created a journey that has a Data Extension entry source, following which there is Service Cloud object activity to populate custom object records from the Data Extension.

When we run the journey, the records in the Data Extension are evaluated, but no records are created in the Service Cloud object.

We have gone through the field mappings and other journey settings, but are not able to identify any possible problems.

Please suggest what are the factors that could be affecting the journey/ preventing the creation of object records.

Thanks a lot for your help!

  • I would start by checking the setup of the Salesforce Marketing Cloud Connect. And as part of that the API Users Permissions. – DonL Jul 3 '19 at 12:14
0

The problems you are most likely facing are:

  • Missing required fields
  • Validation rules in Sales/Service Cloud are triggered
  • Further Logic in Sales/Service Cloud prevents your objects from being created
  • Field Level Security in Sales/Service Cloud is set to Read-Only for some of your fields
  • Missing user permissions (Sales/Service Cloud User)
  • Marketing Cloud Connect Issue

I suggest you start debugging by trying to create a record with exactly the data from your Data Extension via the Sales/Service Cloud User Interface while being logged in using the API User, that is also used for Marketing Cloud Connect. Usually you should see a validation error, etc. that points you in the right direction.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.