0

We are building an application with Ionic 4 and Angular , we are trying to implement MCCordovaPlugin in our application, but we have some issues with it. We want our application to work on Android 4.4 (API 19) to 9.0 .

Actually , it's working fine for Android version > 7.0 ( API 24 ) , for Android version < 7.0 we got the same error message.

enter image description here

On the official Android SDK Marketing cloud documentation , we can see the message :

Version 6.3.3 of the Android SDK has been tested with Google Play Services version 16.0.0 and AltBeacon Library version 2.16.1.
The minimum compatible Android API version is 16. Compiled with Android API version 28.

Is the compatibility the same for Hybrid SDK ? We are using MCCordovaPlugin:6.3.0.

Our Configuration :

Ionic:

   Ionic CLI                     : 5.1.0
   Ionic Framework               : @ionic/angular 4.4.2
   @angular-devkit/build-angular : 0.13.9
   @angular-devkit/schematics    : 7.3.9
   @angular/cli                  : 7.3.9
   @ionic/angular-toolkit        : 1.5.1

Cordova:

   Cordova CLI       : 9.0.0 (cordova-lib@9.0.1)
   Cordova Platforms : android 8.0.0
   Cordova Plugins   : cordova-plugin-ionic-keyboard 2.1.3, cordova-plugin-ionic-webview 4.1.0, (and 9 other plugins)

Utility:

   cordova-res : 0.5.1
   native-run  : 0.2.6

System:

   NodeJS : v10.15.3 (C:\Program Files\nodejs\node.exe)
   npm    : 6.4.1
   OS     : Windows 10
0

Is the compatibility the same for Hybrid SDK ?

The MCCordovaPlugin is simply a wrapper/interface for the SDK and will share the SDK's compatibility and dependency requirements.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.