3

When I go to create a Lightning Email Template, a custom object I recently created doesn't appear alongside other custom objects in the list of objects available for merge field filtering.

What do I need to configure about the custom object to appear as an option in the "Related Entity Type" merge field filter for a Lightning Email Template?

enter image description here

5
  • 3
    The usual things to check are that the object definition has Track Activities checked and is Deployed. But I'm not seeing an object that I changed to Track Activities in the list afterwards, and even tried a different browser to eliminate caching as an issue. Is the object available if you try to create a Classic template for it? Jun 26 '19 at 21:38
  • That did it! I could have sworn I'd checked the "Allow Activities" checkbox in my troubleshooting steps... I must have forgotten to refresh the Lightning page and so didn't refresh the view for the new Email Template modal (aggressive Lightning caching is turned off). Thanks @ThomasTaylor! Jun 26 '19 at 22:06
  • 1
    I had this issue as well. What did it for me was to relog into salesforce. It seems to be a bug that it doesnt appear in the list right away.
    – Andreas86
    Jun 28 '19 at 12:53
  • That must have been it. Thanks for restoring my faith in my sanity, @Andreas86 Jun 30 '19 at 5:24
  • 2
    For me, I had followed all the suggestions above, but the object was still not appearing in the Related Entity Type list. I ended up working on something else for a couple of hours, and then when I went back to try again, the object was now showing. For some reason I just had to wait a while for the object option to appear. I had tried clearing cache, and trying other browsers. The sandbox I was working in also has aggressive Lightning caching turned off.
    – Garywoo
    Oct 6 '20 at 18:16
1

enter image description here

I found the issue and was able to resolve it. Firstly, "Track Activities" should be enabled on the object level. Then navigate to session settings and uncheck the option "Enable secure and persistent browser caching to improve performance". This prevents the browser from refreshing everytime and uses the cookies to load most of the preloaded content. After saving the session settings changes, refresh the browser 2-3 times or do a hard refresh and it should show up the custom objects in the related entity type field.

0

I know this is quite old now but for anyone viewing this and the suggestions above dont fix the issue. I fixed this by enabling "Enhanced Email" in setup.

0

I had this issue too and it was definitely related to caching. After realizing I didn't have Allow Activities checked on the object settings page, I couldn't see it even after logging out and back in. Once I cleared my cookies for the sandbox I was in, it appeared.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.