0

Have a Process Builder condition that isn't working and I'm unsure if its my formula or if it's another part of the PB that is preventing this from working.

This condition is the 4th out of 41 conditions (decision diamonds) in the Process.

I'm testing a Case record to see if it's Case.Status field is new or changed to a picklist value of 'RMA Shipped'.

If RMA Shipped is selected, I then perform an Immediate Action of Updating the Case record Owner to FSI Shipping Queue.

Here's my decision formula:

(
  ISNEW() || ISCHANGED([Case].Status)
 )
&& 
ISPICKVAL([Case].Status, "RMA Shipped")

and here's my immediate action:

PB Immediate Action

Can anyone share if they see any fault in my logic or syntax?

Many thanks,

Paul

2
  • your condition looks like correct. Maybe, your filter could have issue. Also, you could create a debug log and get more info – m Peixoto Jun 26 '19 at 15:44
  • these type problems are more amenable to diagnosis by creating a PB with only 1 decision block and a trivial action - then use debug log – cropredy Jun 26 '19 at 17:57
0

So the answer was way down in the decision node within this PB. I was examining the 4th decision node above. Turns out the 40th, yeah I know, decision node had logic that flipped the field value back to what we didn't want.

Solution: don't make 44 decision node PB's! I'll have to consolidate logic on this one for sure.

Thanks for the replies.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.