3

My current scratch org is expiring today, so I created a new scratch org and tried to push my source. It seems like it's working on the task for a minute or so, then gives me an error with no detail:

ERROR running force:source:push: Push failed.

I don't have a clue how to troubleshoot this. I'm pushing a substantial amount of code, custom objects, permissions, etc., so I'm used to having to tweak my .forceignore file to get things to push. But usually, there is detail in the error that tells me what needs to be adjusted.

I'll try using deploy on some things instead and see if that works.

Not sure if this is related to Summer '19, though my previous scratch org updated and things were working well there.

  • 1
    Possible duplicate of VS Code Salesforce plugin deploy does not provide an error message – Raul Jun 24 '19 at 18:37
  • Nope. -> sfdx update sfdx-cli: Updating CLI... already on latest version: 7.12.3-bfc421fa08 – PatMcClellan__c Jun 24 '19 at 18:41
  • 1
    Oh that suck. try with and without the --json flag and see if it spits more details; from terminal sfdx force:source:push -f, I tried on my summer 19 scratch org and after updating the CLI, it seems to be working. Not sure what could be the issue :( Good luck – Raul Jun 24 '19 at 19:35
  • 2
    Thanks for the --json tip. That yield a list of all the errors I would have expected. Not happy to deal with a long list of errors, but at least I know what they are now! – PatMcClellan__c Jun 24 '19 at 20:11
  • 1
    I'm still working through my errors, and I still have to add --json every time I push. However, although it makes the error list longer (more vertical scrolling), I'm actually liking the JSON output on the errors. Easier to read since there's no wrapping. Also, the JSON output the error twice, once as "result[]" and again as "data[]". Makes it seem worse than it is... HEY, I was writing this as I was waiting for my latest push and it succeeded. Woo-hoo! – PatMcClellan__c Jun 24 '19 at 21:44
3

Posting a follow up so we can close this issue.

After @Raul suggested adding --json to my push command, I was able to get the error detail I needed to adjust my push and get it to work. I don't think the push command was at fault, it was the return of error messages.

After my initial push, I was able to push in the normal way, though if there was a problem with the push, I didn't get the detail unless I added the --json. That was yesterday.

Today, just tried a push with an intentional error. Good news, it balked at the push and gave me the error message like normal. Well, almost normal:

[Line: 16, Col: 1] LWC1503: Parsing error: Unexpected token (16:1) You know you can't fool me with that kind of blatant shenanigans!

Ok, I added that last bit.

| improve this answer | |
  • Thanks for the post I ran into the same issue today and --JSON was the cure. Just a couple of picklist values that were off. – Brooks Johnson Jun 25 '19 at 17:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.