0

We've been working with the Metadata API and keep running into an issue whenever we get sObject details either directly via retrieving a package.xml or even by describing the org through the ListMetadata methods.

We've managed to replicate this in Workbench using the following package.xml file:

<Package xmlns="http://soap.sforce.com/2006/04/metadata">
    <apiAccessLevel>Unrestricted</apiAccessLevel>
    <types>
        <members>Opportunity</members>
        <name>CustomObject</name>
    </types>
    <version>45.0</version>
</Package>

In the resulting zip file, the Opportunity.object file is missing the Label attribute, along with a bunch of others, such as Description, Gender, and DeploymentStatus.

I've tried this in a bunch of orgs, both sandbox and production, and got the same result. Has anyone ever come across this before, or know of a workaround to find these missing attributes? It feels like we are just missing a setting or extra tag in the XML but can't seem to find anyone getting the same issue.

0

Just in case anyone comes across this one, I reached out to Salesforce support and according to them this is 'intended' for any standard objects.

Custom objects will return these other attributes fine, standard will not. The workaround would be the run a REST describe on the standard object to get the missing information.

Salesforce support have said they will update the relevant documentation to make this clear.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.