0

In Marketing Cloud, I have created a Customer Journey with an API event as entry source and a corresponding (sendable) Data Extension. When I make the request to the API with Postman, I only get a 403 Forbidden response with the following message:

"Insufficient privileges to complete this action"

My request body looks as follows, according to this and this posts:

Host: https://MY_SUBDOMAIN.rest.marketingcloudapis.com
POST /interaction/v1/events
Content-Type: application/json
Authorization: Bearer MY_OAUTH_ACCESS_TOKEN

{
    "ContactKey": "abc123",
    "EventDefinitionKey":"MY_API_EVENTKEY",
    "EstablishContactKey": true,
    "Data": {
        "ContactKey":"abc123",
        "EventDefinitionKey":"MY_API_EVENTKEY",
        "DataExtensionColumn1": "Value1",
        "DataExtensionColumn2": "Value2" }
}

Can anybody give me a hint on what I am missing? The Installed Package with API Integration has Read/Write permissions on both Data Extensions and Customer Journeys (and also Execute for Customer Journeys).

  • Have you ensured your app (that you connect via) has the required scope to make the request? That's likely what it is. – Deployment Failure Jun 24 at 11:41
  • What scope is required by the app? Right now it has an API Integration with a scope of Journeys (Read/Write/Execute) and Data Extensions (Read/Write). – Guest9875 Jun 24 at 11:49
  • Was permission given to Journeys in your Installed Package at a point after the package was created? I have found in the past that permissions cannot be changed/updated once the package is created. I am unsure if this has changed in the past couple years. Can you try creating a new installed package, setting the proper permissions at the time of creation, then attempting to use it's credentials for OAuth? – Mike Jun 24 at 13:42
  • Tried it just now, but still the same result unfortunately... – Guest9875 Jun 24 at 14:01
1

I'm almost positive that you're being affected by a recent SFMC security upgrade.

What is going on: SFMC had recently discovered that some REST routes were not following the least access principle in regards to usage, meaning some users could occasionally do more using a route that their access would specifically have allowed.

Here is how to find out what you're missing: Go to the SFMC developer documentation on the subject and run the reports. It will show what you're trying to hit, and where you need to add access. Of course, you don't HAVE to add that access... you may not want some of those users to access those things. Hope this helps!

  • Unfortunately, my installed package does not appear in the report and the error still comes up... I tried with another package without OAuth and then receive this error, although I don't use a Filtered Data Extension – Guest9875 Jul 8 at 9:29
  • I ran the report again after one week and today it told me to adapt the permissions for "Email" and "List and Subscribers". I gave Email Read access and List/Subscribers Read/Write access and now it seems to work... Thanks! – Guest9875 Jul 15 at 10:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.