0

We are getting a message returned from one of our Lightning Components. This was not happening before the Summer 19 Release but is now appearing quite frequently from a component after the latest release. The message is as follows:

Did not find all necessary fields for record: 'aEn0O000000blJOSAY': '{"expectedFields":["Account_Settings__c.Id","Account_Settings__c.Name","Account_Settings__c.Company_Logo__c","Account_Settings__c.Default_Selection__c","Account_Settings__c.Master_Account__c","Account_Settings__c.Master_Account__r.Id","Account_Settings__c.Master_Account__r.Name","Account_Settings__c.Opt_Out_Merchant_Referrals__c","Account_Settings__c.Process_Identifier__c"],"actualFields":["Account_Settings__c.Id","Account_Settings__c.Name","Account_Settings__c.Company_Logo__c","Account_Settings__c.Default_Selection__c","Account_Settings__c.Master_Account__c","Account_Settings__c.Opt_Out_Merchant_Referrals__c","Account_Settings__c.Process_Identifier__c"]}'

This is displayed in the lightning messages tag within a recordEditForm section.

<lightning:recordEditForm recordId="{!v.recordId}" objectApiName="Account">
<lightning:messages />

We have also noticed the following message in the browser console too: {"ok":false,"status":500,"statusText":"Internal Server Error","body":{"errorCode":"DENORMALIZE_FAILED","message":"Did not get a denormalized record back for marker: 0010O00002NxkaYQAR","stack":{}}}

I have checked our code base and also cannot find any anywhere where there is missing fields nor can I figure out exactly what component is generating the error message.

There is a similar issue (however slightly different message) here: Aura Components Bug

Does anyone know of how to resolve this error or have a link to any known issues?

Thanks,

  • Hello Tom, I created a case to Salesforce for this bug, It is the same bug than "Aura Components Bug". Salesforce team is working actively to send a corrective patch to this issue. For now the only way to fix this is stop using lightning data service. But I hope that soon we have this fixed by Salesforce team. – Elias Pinheiro Jun 26 at 13:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.