2

I'm getting an internal server error message, wondering how I track down the cause?

I have a custom lightning component (lwc) that runs fine when dropped into a tab on a Campaign record page. Previously, it also worked when dropped into a tab on a custom object record page. Now, I'm getting an error when I try to load that record page (or any record page for that custom object).

If I go into Lightning App Builder (LAB) and pull the component off the page, it loads fine, so it's something to do with my component.

In LAB, I can drop it into the tab, and I see that it loads up fine. It generates logs that I can see, successfully reading the page's recordId and calling Apex for data. Looks great in LAB. Saved, activated, return to the main record page, and nothing on that page loads. Instead, I get this error:

Looks like there's a problem.

Unfortunately, there was a problem. Please try again. If the problem continues, get in touch with your administrator with the error ID shown here and any other related details. An internal server error has occurred Error ID: 1717890395-229230 (-1122514613)

So, what's the procedure/resource for tracking down an error when you have the ID?

2

It sounds very similar to this post? So I am thinking there is some bug with summer 19. Though I tried to re-create and couldn't - so not sure if it is an instance thing, a namespace issue or something else?

If you have access to Partner Support, I would raise a case there. Typically, regular support won't accept Dev Support requests (even though it is a bug - a group of us in community are trying to get that changed, but it's an issue for now)

Might also be worth posting in the Lightning Web Component Group in success since that seems fairly active https://success.salesforce.com/_ui/core/chatter/groups/GroupProfilePage?g=0F93A000000LlT2

| improve this answer | |
  • 1
    I did file a Partner Support case and they already got back to me (same day!). It's a known-issue, bug in Summer '19, due to be fixed in the first patch update next week. – PatMcClellan__c Jun 22 '19 at 21:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.