2

it was working earlier this week, but starting from June 18th I believe after SF pushing upgrade or something, it stopped working.

add custom LWC to lightning record page for standard object still works, however, if it's for custom object it will not work.

to re-produce, create a simple test LWC and add it to a custom object lightning record page:

test.html 
<template> Test LWC </template> 

test.js
import { LightningElement } from 'lwc';

export default class Test extends LightningElement {}

test.js-meta.xml 
<?xml version="1.0" encoding="UTF-8"?>
<LightningComponentBundle xmlns="http://soap.sforce.com/2006/04/metadata" fqn="test">
    <apiVersion>45.0</apiVersion>
    <isExposed>true</isExposed>
    <targets>
        <target>lightning__RecordPage</target>
    </targets>
</LightningComponentBundle>

Tested in scratch org, it always says something like this below:

Looks like there's a problem.

Unfortunately, there was a problem. Please try again. If the problem continues, get in touch with your administrator with the error ID shown here and any other related details.

Anyone experienced the same issue? Any ideas how to solve this? Thanks in advance

per call with Partner Support (6/25), they are saying they will be rolling new patches to fix a variety of LWC issues (including the one I have within the managed package). So hopefully it will be fixed soon

8
  • Can you add code snippet so that we can reproduce same? Jun 20 '19 at 15:51
  • It is working ok for me in a namespaced org, though your sample is missing the <target>lightning__RecordPage</target> so not sure how you adding it to the page? Jun 20 '19 at 22:45
  • @BritishBoyinDC, my mistake, forgot to add that, updated with test.js-meta.xml. Did you add it on a custom object record page in namespaced org (summer 19?) I tried with dev hub scratch org and stand-alone packaging org(dev edition), both had the same error though
    – red
    Jun 21 '19 at 3:28
  • 1
    @BritishBoyinDC, thank you , i will raise a case with them
    – red
    Jun 21 '19 at 15:05
  • 1
    @ThomasTaylor, setting api version to 46 does not help
    – red
    Jun 24 '19 at 18:52
0

I had the same error, reported here, and I filed a Partner Support case on it. They report that it's a known-issue, bug in Summer '19, due for a patch next week.

Just checked (Monday June 24) and it appears to be fixed.

5
  • Same issue still persists, havent heard anything back from Partner Support since filed a case with them last Friday:(. Anyway, i'll just have to wait for the patch if it's bug from their side
    – red
    Jun 24 '19 at 14:43
  • 1
    The testing results are inconsistent. it seems to be working in some of our orgs now, but some are still not working including org uses our custom built LWC within a managed package
    – red
    Jun 24 '19 at 18:45
  • Maybe they're rolling out the patch... can't do all orgs at the same time? Jun 24 '19 at 18:54
  • @red did this eventually get fixed for you? It got fixed in our dev orgs but we have now created a managed package, and when we deploy this to a test org, we get the same again :(
    – zaitsman
    Sep 2 '19 at 7:37
  • @zaitsman, no, it is still happening with installed managed package. It's been out there for quite some time success.salesforce.com/issues_view?id=a1p3A000001SHvtQAG
    – red
    Sep 9 '19 at 16:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.