0

Full Error message:

System.DmlException: Process failed. First exception on row 0; first error: CANNOT_INSERT_UPDATE_ACTIVATE_ENTITY, A workflow or approval field update caused an error when saving this record.

Contact your administrator to resolve it. common.exception.SfdcSqlException: ORA-20067: ORA-06512: at "DOC.CPICKLIST", line 3388 ORA-01403: no data found ORA-06512: at line 1 SQLException while executing plsql statement: {?=call cPicklist.get_or_make_new_pick_apextest(?,?,?,?)}(EXCLUDED (2), EXCLUDED (25), EXCLUDED (25), EXCLUDED): []

Stack Trace: Class.Order_AutoApprove_Batch_Test.testMethodOne: line 77, column 1

The code I have at 77th line of test class is

Approval.ProcessResult result = Approval.process(req1);

The same code was working fine in UAT (SeeAllData is not true). But it is not working when I am validating the Change Set in Production.

Same error is occurring in all the places that I have this line in test class.

  • 3
    You need to contact support. See this question. – sfdcfox Jun 20 '19 at 14:57
  • @sfdcfox is the 7 dwarves error a gack, or do we need a a new tag? – PartOfTheOhana Jun 20 '19 at 15:21
  • 1
    @PartOfTheOhana I'd say that this probably falls under the platform-bug. – sfdcfox Jun 20 '19 at 15:26
  • Thanks @sfdcfox. As suggested, I have raised a case to Salesforce Support. Will post it here for reference as soon as I hear from them. – K Nandeeswara Raju Jun 20 '19 at 18:12
  • Hi All, I raised a case to Salesforce Support and heard that they have seen this kind of issues and mostly due to dependency among components. As a workaround, they recommended me to do an Incremental Deployment to avoid much dependency between the components. Luckily, that worked out to me when I split my single change set into 7 change sets. – K Nandeeswara Raju Jul 1 '19 at 14:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.