0

I am trying to send a Salesforce Survey, but when I get to step 2 of the Send Email wizard, I get this error:

We couldn't find the record you're trying to access. It may have been deleted by another user, or there may have been a system error. Ask your administrator for help.

Questions

  1. What am I doing wrong?
  2. How do I fix it?

1

Make sure you have a Global Action that has its default name: SendEmail.

There are three more things to keep in mind for this to work:

  1. Ensure Setup > Deliverability > Access to Send Email org wide pref is set to "All Emails" (this is OFF by default in Sandbox orgs, and also on trial orgs which haven't verified the user email address)

  2. Ensure the user has the Send Email user perm (which also adds the Edit Tasks user perm)

  3. Ensure that the Send Email Action is added to Lightning Actions in the Page Layout. Please note these three are requirements of the feature, not part of the Bug.

0

I've had this issue, Solved by creating a new Lightning Email Template with the name 'Embed_a_Survey_Link' make sure to include the survey link in it <a href="[[SURVEY_INVITATION_URL]]" ... />

0

In addition to Rashmi's answer. I had changed the Deliverability to All Email and the SendEmail action was already on the Publisher layout. I still ended up with this error.

Situation: We had just preformed a sandbox refresh and then every user has to configure the email settings.

Solution: You can do this by sending an email through any record. Then select: Send emails through Salesforce OR Connect to Office 365 (in our case). I chose 'No, Use Salesforce' and that worked :)

0

In addition to Rashmi's answer, remember to enable "Lightning email template" inside the setup menu.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.