I'm working on a use case, in which a contact enters a journey. The purpose of Journey is only to send sms. 1st SMS sent as contact enters the journey. After 3 days, contact changes his mobile number and gets updated in MC data extension. On the 5th day of Journey, second SMS is sent. But needs to be sent on new mobile number. Can anyone help me out, how to update the new mobile number for SMS, so that SMS will get received only to new mobile number of the contact.

Thanks in Advance.

1 Answer 1


You can achieve that by choosing the default mobile number from your Journey settings. Go to your Journey > Journey Settings > Default Mobile Number

enter image description here

Then choose the option:

  • Select Use email attribute from Contacts. If the email address could change, as in a journey with a long duration, choose to use the email attribute associated with Contacts.
  • Select Use email attribute from Entry Source. If a contact’s email address or mobile number is not likely to change during a brief
    journey or a journey that does not allow re-entry, choose to use the
    email attribute associated with the contact at entry.

Reference: Journey Settings

  • How to achieve this? I'm not able to get SMS on updated mobile number. Can you please help me with this? I think the mobile number is not getting reflected in Mobile Contact list, after updating Mobile Number in DE. Jun 20, 2019 at 7:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .