0

I have a process built in process builder that will submit a record through an approval process once certain criteria is met. The purpose of the approval process is to lock the record so changes can't be made to it. Up until ~a weekish ago, everything was working as it should but now I'm seeing flow errors come through of:

Error element myRule_3_A1 (FlowActionCall). No applicable approval process was found.

&&

We can't save this record because the “Case Management” process failed. Give your Salesforce admin these details. An unhandled fault has occurred in this flow An unhandled fault has occurred while processing the flow. Please contact your system administrator for more information. Error ID: 1547086354-122488 (-2108862642)

This error will happen after the status is changed to "Closed". I tried to log in as the user to duplicate the issue and was successful in recreating it, however if I close the case, I don't run into any issues.

From what I have read, if the submitter doesn't have FLS to the entry criteria, this can happen. She didn't originally have access to the field in the criteria, which I granted her Read Access to, but still had the same error. Even tried removing the criteria all together.

Any ideas on what may be the issue for this?

  • After some additional troubleshooting, I determined that if I log in as the case owner, rather than a user that has read/write access via Account Sharing, this worked. But, that's not how it's always been. Somehow need to figure out how to get it so users that have read/write access can close the case/go through the approval process without issues. – tDactyl Jun 20 at 13:14
0

In my Approval Process, I have the "initial submitter" set as "Case Owner". Updated this to "All Internal Users" (group), so this is no longer an issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.