VS Code plugin for salesforce seems to be broken yesterday, It does not provide proper error message in case of failure.

Tried this in a developer org as well as scratch org. Neither deploy code or push gives an error message, and every time we need to go to Salesforce setup -> Deployment Status to view the details.

Is anyone aware of any workaround?

enter image description here

  • You have 1 problem on the PROBLEMS tab. Did you check that?
    – sfdcfox
    Jun 19 '19 at 12:58
  • @sfdxfox unfortunately nothing there, added the screenshot. simply says Push failed.
    – Raul
    Jun 19 '19 at 13:01
  • 2
    Try sfdx force:source:push -u username-or-alias -w 10 --loglevel trace --verbose, you might get better output (use the terminal). Usually errors like this are from missing metadata in the repo, but without an error, might be difficult. The above command should give you more information.
    – sfdcfox
    Jun 19 '19 at 13:04
  • seems push command does not have a --verbose, ERROR running force:source:push: Unexpected argument: --verbose :(
    – Raul
    Jun 19 '19 at 13:11
  • 1
    For what it's worth, the "workaround" I used was to open the org and view the errors under Deployment Status.
    – Charles T
    Jun 21 '19 at 12:07

Seems to be working now, also noticed this issue is logged on github salesforcedx-vscode project-

For the fix to work, we need to update the sfdx CLI with sfdx update command, latest sfdx working version on my machine is sfdx-cli/7.12.3

  • The issue is open, updating sfdx won't do anything yet. I think maybe you mistook the linking of issue #871 at the bottom, which isclosed, as inidcating that this new issue, #1411, is closed. Can you edit your answer? Jun 21 '19 at 13:09
  • 1
    Oh, yesh @ThomasTaylor you're right, but somehow it works now. This started working for me after updating sfdx CLI, also verified with my colleague. :) btw we are working on sandboxes; so using deploy command.
    – Raul
    Jun 21 '19 at 13:23
  • 1
    Solved my issue as well. I went from 7.11.2-4a5bf6aa97 to 7.12.3-bfc421fa08. Jun 24 '19 at 19:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.