3

I ran into an issue whereby I created a hierarchy custom setting in my DX scratch org but when I used the SDFX CLI to pull down the metadata it was ignored.

I had used list custom settings before and that was fine. Of course, to use list custom settings you need to enable Schema Settings > Manage List Custom Settings Type first.

As it turns out, after enabling that, I was able to update my original hierarchy setting and, voila, then able to pull it down with the CLI.

I could not find any documentation around this behavior but would like to know if anyone knows whether it is possible to create and pull hierarchy custom settings without enabling list types as well?

  • Interesting. Cannot reproduce - tried both before updating CLI to Spr '19 with an org I created a week or so ago, and also after updating CLI with a fresh scratch org. In both cases, with Manage List Custom Settings Type off, I was able to create a hierachical custom setting with 2 fields and retreive it with sfdx force:source:pull. Did this happen more than once to you? – Thomas Taylor Jun 18 at 15:34
  • I only experienced it in one org with the 7.8.1 CLI, but didn't test it out in others. Perhaps the org was messed up somehow. I did pull and just assumed everything came down, but when I went to build the package it told me the object was missing. Interestingly, IntelliJ/IlluminatedCloud was still able to build the offline symbol table with that object. Not sure how pervasive this is, but hopefully if anyone else runs into it, this worked to get me back in business. – Shane Jun 18 at 18:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.