0

For some reason the _emailid in Email Send context returns back the legacy Email ID value instead of the Asset ID. Using what data we have (and because theres no other options) I have to query the Asset ID using the API /asset/query.

Here is the query parameters I've tried using but haven't been successful:

{
  "query": {
    "property": "legacy.LegacyId",
    "simpleOperator": "equals",
    "value": "XXX"
}

I've tried property:assetType.id which has been unsuccessful and I cant use the property:Id as that refers to the "Asset ID", which is the value I'm trying to get.

Edit:

{
    "query": {
        "property": "Data.Email.LegacyData.LegacyId",
        "simpleOperator": "equals",
        "value": 16696
    }
}
  • I think the correct path might be legacyData.LegacyId – Gortonington Jun 18 '19 at 11:09
  • I tried this, doesn't seem to work :( – Deployment Failure Jun 18 '19 at 11:10
  • Try the full path Data.Email.LegacyData.LegacyId – Gortonington Jun 18 '19 at 11:15
  • That didn't work either (returned no results), I have updated my original question incase the syntax is wrong. – Deployment Failure Jun 18 '19 at 11:23
  • 1
    I will try to look more into it later once I can get to a computer and see if I can find the issue – Gortonington Jun 18 '19 at 11:24
1

I know this question is pretty old, but I recently ran across the same issue and had luck by querying the path data.email.legacy.legacyId.

My api call looked like /asset/v1/content/assets?$filter=data.email.legacy.legacyId eq {{legacyId}}

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.