Followed a module in trailhead and when i got to the part where i was needed to deploy my work using this command

sfdx force:mdapi:deploy -d mdapioutput -u MyTP -w 10

it throws an error. saying:

ERROR running force:mdapi:deploy: Specify the number of minutes to wait as a numerical value greater than or equal to -1. You can specify a decimal value if it is greater than 0.

also tried the --wait parameter in deploy:report -w 10. still throws the same error. Am i doing something wrong?


1 Answer 1


I wonder if -w 9 would work for you.

Maybe the problem, just a guess, is when the minute contains 2 digits.

If -w 9 works, try -w ”10”

  • Tried your suggestion but still throws the same error. Wonder why, do you encounter this kind of error? My deployment not getting completed due to this error. It defaults to 0 mins waiting time.
    – Clyde
    Jun 18, 2019 at 3:14
  • and i thought the default value was supposed to be -1 which means until it completes. yet it stops deployment coz it says that deployment taking too long and that 0 minute is not enough.
    – Clyde
    Jun 18, 2019 at 3:15
  • 2
    It works for me. Try to use the command ’sfdx update’ via cmd, maybe you are not using the most updated version of the CLI?
    – Derminal
    Jun 18, 2019 at 7:39
  • 2
    thanks! Worked after i updated sfdx. thanks so much!
    – Clyde
    Jul 16, 2019 at 11:12
  • I'm glad to hear that
    – Derminal
    Jul 16, 2019 at 14:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .