0

We have a triggered send configured in Marketing cloud instance. This triggered send uses one of the emails in the system. When I configure and save this triggered send, I get an error as:

enter image description here

When I go tho the selected email in this triggered send, and do a Preview and test, I do get 6 validation errors as:

enter image description here

These error basically mean that some fields/objects were not found that were referenced in "RetrieveSalesforceObjects" function. When I check the synchronized data extension for Case - that is being used in this object - for the fields, they are present there. So even then why the error is coming?

I think that while doing a Preview and Send for email template, we have to select a data extension, and we can not select synchronised DE in this. Resultingly, it does not find a case record and throws an error. This is understandable. But then the triggered send should not throw an error at least when this email is referenced there.

Please note that in our dev orgs, error keeps coming during 'Preview and Send' of email , though it allows Triggered send to be saved successfully. However, it is in Prod org that it throws the error while saving.

  • i believe its the same issue than this salesforce.stackexchange.com/questions/265881/… – Johannes Schapdick Jun 17 '19 at 10:38
  • @JohannesSchapdick : That question speaks about extra <br> or &quote character coming in ampscript. I can't see any such character when I pasted my code in notepad. Do you have any more suggestions? Appreciate your comment. – Sarang Jun 17 '19 at 11:15
  • 1
    When you paste your code from notepad or whatever to a TEXTAREA instead of an html block or codeblock of salesforce it will transform / wrap / encode new lines to <br> or something similar which can break your code. – Johannes Schapdick Jun 17 '19 at 11:18
  • @JohannesSchapdick : I tried separating text and code blocks by creating separate type of blocks for each. Still it gives me the error :( – Sarang Jun 17 '19 at 12:16
0

You will have to specify the Salesforce object and it needs to be in quotes. See RetrieveSalesforceObject documentation.

Specify the standard or custom object. I do not believe that generic sObject will work.

| improve this answer | |
0

The reason for this error was because "Selected Active Data Extensions" did not contain any DE. We need to create a DE specially for triggered send which should be created from a template called "TriggeredSendDataExtension". These are the detailed steps:

https://help.salesforce.com/articleView?id=mc_co_create_triggered_send_data_extension.htm&type=5

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.